A Table and Style Example

This is an example which may be of special interest to language teachers, but the principle can apply in a number of applications.

(Note: This example uses Word 2010, and hence may not appear exactly as other versions of Word.)

What we are doing here is essentially producing a table of words. An English word, followed by its French and Spanish translation. For example:

Word List
English Franšais Espa˝ol
boy garšon chico
girl fillette chica
table table mesa
chair chaise silla
apple pomme manzana
orange orange naranja

You can type this directly into DBT's editor, but you would then have to manually apply the french and spanish styles to the appropriate words or phrases. Fine if you have a short list, but rather laborious if you have a long one.

One solution is to create a table in Word. From Word's "Table" menu, select "Insert", and then "Table" which will then display the following dialog. For this example, make sure you select 3 columns. (You do not need to worry about the number of rows.)

Image of Word's Insert Table dialog.

You may now complete your table as shown below. Note that when you tab from the bottom right hand corner box, a new row will be created automatically for you.

Word List
English Franšais Espa˝ol
boy garšon chico
girl fillette chica
table table mesa
chair chaise silla
apple pomme manzana
orange orange naranja

We now need to create two styles in Word - french and spanish.

From Word's Format menu, select "Styles and Formatting" and then click on the New button, which will display the following dialog.

Image shows Word's New Style dialog with the font colour option showing.

In the Properties, Name: text box, type in your style name e.g. french.

Next, make sure you select "Character" for Style Type - THIS IS IMPORTANT!

For visual help, we suggest you may wish to select a different color font for your french Style. Click on the A icon to bring up the color choice grid show above, and then click on a colour.

Now press the Format button, select "Language" from the drop down menu, and from the Language dialog, select French (France) or whatever language you wish.

Image shows the dialogs which come up when the Format button, then Language is selected.

Click on O.K. (Twice) to return to your document.

Repeat the above exercise to create a Spanish character style, but this time select a different color, in our example here we have used blue.

So what have we done so far?

1) We have created two Character Styles for use in Word, which also happen to be called the same Style name in DBT.

2) We have made it easy to identify them in our document by color.

3) Because we have also chosen a Language, Word can also Spell check our document.

(Note: You may have to install the additional language dictionaries on Word)

-----------------------------------

Now we need to apply these styles.

We first need to select a column. You can do this in two ways. Place your cursor in the appropriate column and 1) Go to Word's "Table" menu, choose "Select" and then "Column", or 2) move the I bar cursor slowly UP until it changes to a down pointing arrow, then click the left mouse button.

Image shows the Word table with the French column selected.

When the column is highlighted as shown above, click on Word's Style drop down list, and select French.

Select the Spanish column in the same way, and apply the spanish Style to it.

(Note how there are some words with a red wavy underline indicating a spelling error.)

Your Word table should now look this.

Image shows the Word table with french (red font) and spanish (blue font) styles applied

Note that because we have elected to check spelling, there are no wavy red lines showing now.


You now have two choices, and which you select is entirely up to how you wish your table to be presented in braille.

Choice 1) Stairstep Table format.

This format is recommended in many countries for tables, but does tend to use more paper since each table cell is on a row of its own. However for very wide tables and or those which have many columns, it tends to be the preferred method.

If you have DBT's SWIFT installed in Word, you may click on the "Duxbury Braille" option which will import your file into DBT. Otherwise save your Word file, and import it into DBT in the usual way.

Image of the first item (Duxbury Braille) of Word's DBT menu which is part of SWIFT.

Note how each table row begins in cell 1, with subsequent cells on a new line, and indented 2 cells.

image of part of the imported DBT dxp (print) file.     Image of part of the translated braille file showing stairstep format.

Choice 2) In-line format.

This requires a little additional effort on Word, and may in some cases be preferred, especially since it uses less paper.

Place your cursor anywhere in the table, and from Word's Table menu, choose "Select", and then "Table". Your complete table should now be highlighted.

Go back to Word's Table menu, select "Convert", and the "Table to Text".

image showing part of the Word Table, plus Word's Table menu, Convert, Table to Text.

The following dialog will appear.

image shows Word's Convert Table dialog.

In this example, we have used a hyphen (-) to separate the text between cells. When you click on OK, you Word table will now appear as follows:

image shows the table converted to text, and separated by dashes.

You may now save your file, and either use SWIFT to open it in DBT, or otherwise open it in DBT as normal. When you translate, you will now find each row of your table appears on one line.

Image shows DBT print and translated braile file in in-line format.

For the more technical:

If you turn on DBT's Coded View (Alt + F3) you will see that the appropriate french and spanish character styles have been applied to the text.

Image shows the dxp (print) file with Codes viewed.